Seems that latest joomla 1.5.26 is not well protected. New exploit and protection.